Help ! Futaba S3003 Servo problems

Home Forums 1/8, 1/10, 1/12, 1/18 – Discussion Help ! Futaba S3003 Servo problems

This topic contains 10 replies, has 7 voices, and was last updated by  PandaBear 11 years, 6 months ago.

  • Author
    Posts
  • #12616

    kevsta
    Participant
    • Posts: 973

    I m running this servo in my mini cooper and it s not centering properly. I turn it left and right with no problems, some times it can straighten up but other times it will be slightly off. I don t think it s my radio trim settings.

    There is no binding in the steering arms and linkages etc. I ve opened it up to check the teeth in the gears and all is fine.

    Is it time to get another servo ? This servo has only had about 5 runs on it.

    Thanks.

  • #59323

    TallduDe
    Participant
    • Posts: 1430

    try another servo dude, if the problems does not occur again its the servo but if it happens again could be the radio or the receiver?

    cant hurt to try aye

  • #59326

    betty.k
    Participant
    • Posts: 2485

    sounds obvious but are you certain it’s the servo? check all the steering linkages to be sure. i’ve had one that i got second hand and i use it in my rs4 mt without a prob:8ball:

  • #59328

    kevsta
    Participant
    • Posts: 973
    Quote:
    sounds obvious but are you certain it’s the servo? check all the steering linkages to be sure. i’ve had one that i got second hand and i use it in my rs4 mt without a prob:8ball:

    Yeah checked all my steering links and the servo saver for any damage, but all is okay – nothing broken.

    It’s like the servo doesn’t have enough strength to recenter properly within 5mm of the correct centre, and thats after turning left only.

    I’ll do what TD suggest and move my touring car s3003 servo to the mini to see what happens…

  • #59329

    merc-blue
    Participant
    • Posts: 1547

    talldude the main reason people use s3003s is so when they go (sounds like urs has) u go buy a new one.. cause there cheap its a good way to do it.. i go through 1 a month ive bitten the bullet and got a topline hitec on the way
    minis kill servos pretty easy so i think it might be gone.. try opening it up sounds like the tooth of teh big gear is gone right in the middle.. sit the car on the ground and dry steer it try to listen for any clicking..

  • #59332

    mini-g
    Participant
    • Posts: 267

    yeah sounds like you have done a gear in the servo…. but they only break if you hit something hard:dead: otherwise they work well. have had one in my mini for years now.

    BIG DAVE

  • #59333

    kevsta
    Participant
    • Posts: 973
    Quote:
    yeah sounds like you have done a gear in the servo…. but they only break if you hit something hard:dead: otherwise they work well. have had one in my mini for years now.

    BIG DAVE

    Just got one priced at the lhs for $22.95, so I’ll just get a new one.

    Thanks for all the help everyone.

    😀

  • #59334

    PandaBear
    Participant
    • Posts: 1865

    You can buy a new set of S3003 gears for < $5… 🙂

  • #59337

    merc-blue
    Participant
    • Posts: 1547

    yeah panda ur one of them fellows who swears by s3003s.. lol.

  • #61899

    Admin
    Participant
    • Posts: 5949

    I had smoke coming out of my s3003, is there anyway of repairing it? Also wheres a cheap place to buy new ones?

  • #61900

    PandaBear
    Participant
    • Posts: 1865

    Not worthwhile repairing unless you’ve got another S3003 with a broken
    motor/case/gears… then you’d just swapover the electronics board.

    Any LHS should stock them for say $15-20.

    And don’t throw away the old one – useful as spares for the gears, motor, case etc.

You must be logged in to reply to this topic.