Mini-T esc and 300 motor – ok?

Home Forums 1/8, 1/10, 1/12, 1/18 – Discussion Mini-T esc and 300 motor – ok?

Viewing 3 reply threads
  • Author
    Posts
    • #12643
      Kerosene
      Participant
      • Posts: 329

      Anyone know if the Mini-T stock esc/rx will run a 300 motor without frying?

      I’ve just ordered a new Graupner 300. Seems lots of people use them with Mini-Ts, but I’m not sure if they’re using the standard esc/rx or not.

      My stock motor died today, not sure what happened – it just locked up. Only got about 5 runs with it, so I guess everything I’ve read about the stock motor being total junk is true. It did have a fair amount of grit in it when I opened it up though. Other than that the T is taking everything I can throw at it.

      • This topic was modified 7 years, 8 months ago by Avatar photoAaron.
    • #44080
      ph2t
      Participant
      • Posts: 2088

      It should be fine. The grappy speed 300 (6V version) is an excellent motor.

      Just install it and run it without any load and keep your finger on the fets/heatsink. If it gets hot quickly, then remove the motor. If it doesn’t then give it a go installed but still free standing. If it’s still ok, then do a few runs without any hard breaking/stopping/starting. If it survives that then you should be fine.

      A couple things to do to the grappy to make it even better. (learnt from my RC18T days….).

      Oil the bushings on each side.
      Break the motor in for 30 – 60 minutes using 2-3 AA’s.

      Good luck dude!

      ph2t.

    • #43558
      Kerosene
      Participant
      • Posts: 329

      Thanks ph2t, that’s some good info.

    • #31283
      Kerosene
      Participant
      • Posts: 329

      And it all works!
      I did a crap job dremeling out the motor plate, but it all fits in and work good.

      ESC gets warm (but not hot), motor gets hot, car goes fast.

Viewing 3 reply threads
  • You must be logged in to reply to this topic.